HRD-DM780 Member and LONP Member Alarm Uploads


Rick - N7WE
 

Due to all the Google changes, the hamclub.info 070 alarm definitions file is no longer current and can't be fixed.  I have uploaded a new XLM definition file that has all current members to 7/30/2021.  Regular members are shown with a Lite Blue background and black text  Current LONP members are shown with a Green backgound and the black text.  You may want to change the text color of those members you have worked.

I also uploaded a revised "how to" article that provides help on how to load the definitions and set it up in SuperSweeper.

I hope to update the definition file periodically and that you find this useful.
--
Rick - N7WE
070 - #1602


Barry VA7GEM
 

Rick
TVM for taking on this valuable undertaking.
cheers
Barry


Rick - N7WE
 

Barry - Your Welcome!  My pleasure.  Need something to do indoors while the heat and humidity hangs about.

And Barry, would you test it and confirm all works as it should?  I'm in the throws of migrating HRD from a Win 7 machine to a new Win 10 laptop and can't get alarms to work in SuperSweeper on the 10 machine.  All works FB on the old Win 7 machine.  Also, SuperSweeper crashes DM780 when you click on a call!  I've tried a lot of suggestions (Thanks Paula K7PAX and Buz WA5AMM) but so far no joy.  Works fine from the Main QSO window...go figure!  Oh the joys of migrating from one OS to a new better one!
--
Rick - N7WE
070 - #1602


Paula K7PAX #1739
 

Barry, Buz and Rick - I downloaded and enabled the alarm file and tested. It did not work for me either, in the one contact I made today. But I need to look through the alarm file to find whether that callsign is even present.

Since there are not a lot of workstations on, it is hard for me to sort through the callsigns in the alarm file to make sure the station I tested with is present on the alarm file since they do not appear to be in any particular order. It would be great if it were in callsign order so we could quickly find out if a callsign is present, and play with the alarm settings while still in QSO with the station. Ideas?

Paula K7PAX

On Jul 31, 2021, at 12:20 PM, Rick - N7WE <n7we1980@...> wrote:

Barry - Your Welcome!  My pleasure.  Need something to do indoors while the heat and humidity hangs about.

And Barry, would you test it and confirm all works as it should?  I'm in the throws of migrating HRD from a Win 7 machine to a new Win 10 laptop and can't get alarms to work in SuperSweeper on the 10 machine.  All works FB on the old Win 7 machine.  Also, SuperSweeper crashes DM780 when you click on a call!  I've tried a lot of suggestions (Thanks Paula K7PAX and Buz WA5AMM) but so far no joy.  Works fine from the Main QSO window...go figure!  Oh the joys of migrating from one OS to a new better one!
--
Rick - N7WE
070 - #1602

--
Paula K7PAX #1739


Rick - N7WE
 

Paula -
The alarms are in 070 # ascending order.  I guess it was originally set up that way because it was linked to and derived from the membership list.  It used to automatically update. But the order is still handy as you can just add new members at the end of the list as they occur.  It is an XLM file and beyond my capabilities to sort the order of the list.  Maybe someone else can. 

But you are right, too few on the waterfall makes it hard to find a known member.  I did see Jerry N9AVY last night and he didn't trigger the alarm on the Win 10 machine.  Thank goodness the old Win 7 computer is still semi-functional and the new alarm def file worked FB on it.  Jerry popped up with a green background (LONP member). 

Not sure what is going on with my setup, but I'm sure it relates to my SuperSweeper crashing DM780 when I click on a call.  

--
Rick - N7WE
070 - #1602


K8TOM
 

Paula,

There is a robust "Find" feature in the Alarms which allows you to find call signs directly or by using wildcards and other logical entries.

I've used it many times for different reasons.  My alarms are in 070 member order which I prefer, since that way I can easily find a recently worked member using the received 070# and then uncheck the alarm box for that call.

I'm an HRD throwback, still using the old 5.24 version, the last released by Simon.  Works great for me on Windows 10, though. YMMV.

Tom
K8TOM
815


Barry VA7GEM
 

On Sat, Jul 31, 2021 at 01:08 PM, Paula K7PAX #1739 wrote:
Barry, Buz and Rick - I downloaded and enabled the alarm file and tested. It did not work for me either, in the one contact I made today. But I need to look through the alarm file to find whether that callsign is even present.
 
Since there are not a lot of workstations on, it is hard for me to sort through the callsigns in the alarm file to make sure the station I tested with is present on the alarm file since they do not appear to be in any particular order. It would be great if it were in callsign order so we could quickly find out if a callsign is present, and play with the alarm settings while still in QSO with the station. Ideas?

Paula K7PAX

On Jul 31, 2021, at 12:20 PM, Rick - N7WE <n7we1980@...> wrote:

Barry - Your Welcome!  My pleasure.  Need something to do indoors while the heat and humidity hangs about.

And Barry, would you test it and confirm all works as it should?  I'm in the throws of migrating HRD from a Win 7 machine to a new Win 10 laptop and can't get alarms to work in SuperSweeper on the 10 machine.  All works FB on the old Win 7 machine.  Also, SuperSweeper crashes DM780 when you click on a call!  I've tried a lot of suggestions (Thanks Paula K7PAX and Buz WA5AMM) but so far no joy.  Works fine from the Main QSO window...go figure!  Oh the joys of migrating from one OS to a new better one!
--
Rick - N7WE
070 - #1602

--
Paula K7PAX #1739
Paula
Not sure if you found how to sort the alarms but this might help.
open DM7800
open TOOLS/ALARMS
This is same panel you use to import Rick's list
Click on the word Title at the top of the list of callsigns.
The list should sort in ascending/descending order
GL de Barry


Barry VA7GEM
 

On Sat, Jul 31, 2021 at 12:20 PM, Rick - N7WE wrote:
Barry - Your Welcome!  My pleasure.  Need something to do indoors while the heat and humidity hangs about.

And Barry, would you test it and confirm all works as it should?  I'm in the throws of migrating HRD from a Win 7 machine to a new Win 10 laptop and can't get alarms to work in SuperSweeper on the 10 machine.  All works FB on the old Win 7 machine.  Also, SuperSweeper crashes DM780 when you click on a call!  I've tried a lot of suggestions (Thanks Paula K7PAX and Buz WA5AMM) but so far no joy.  Works fine from the Main QSO window...go figure!  Oh the joys of migrating from one OS to a new better one!
--
Rick - N7WE
070 - #1602
Rick
I have the file loaded and on the surface in appears good.
All members are there and all alarms are on. I see no colours
on the LONP entries and don't know how to add them.
I have yet to catch an active station to see if it actually works.
It is basically the same list I have and I just turn the alarm off
to signify that I have worked that station.
cheers de Barry


Barry VA7GEM
 

On Sat, Jul 31, 2021 at 03:16 PM, K8TOM wrote:
Paula,

There is a robust "Find" feature in the Alarms which allows you to find call signs directly or by using wildcards and other logical entries.

I've used it many times for different reasons.  My alarms are in 070 member order which I prefer, since that way I can easily find a recently worked member using the received 070# and then uncheck the alarm box for that call.

I'm an HRD throwback, still using the old 5.24 version, the last released by Simon.  Works great for me on Windows 10, though. YMMV.

Tom
K8TOM
815
Tom
It would be a great help if you could explain how to use it.
TVM de Barry


K8TOM
 

Barry and Paula,
 
It is in the V4.0 User Guide included in the Version 5.24 installation.
The Guide is accessed by the "Help" menu item in DM780.  See page 75.  It's called "Testing" but it actually works as a find function.  See the additional comment on "Match" following the screen cap below.


Simon included much more information about the logic of the match function in an earlier DM780 user manual available on qsl.net.  https://www.qsl.net/wb4bxw/software/hrd_archives/DM780%20V5%20UserGuide.pdf
 
See pages 45-46 on the "Editor" topic to review the logical operators for the match.



I hope that the screen caps appear and that the info is useful for you and other 070 member DM780 users.  I have no idea whether it is still present or operable in the current paid versions.
 
Tom
815


Barry VA7GEM
 

Tom
TVM
I thought that might be the function you were referring to.
When I try using it in Digital Master 780 v6.7.0.357 it does not work.
TVM de Barry


Barry VA7GEM
 

Tom & Rick
I had mentioned that The Alarm Test did not work in the current version of HRD so I 
tried to open a trbl report with HRD as below
"In DM780 I have all PODXS070 members listed as alarm defaults.
Whem I open Alarm Manager and click TEST button a panel opens
for me to enter data. If I enter one of the call signs in the list and
press the test button that call sign is not highlighted in any way.. I
thought the X should be replaced with anouther symbol.
TVM for the help
Barry
va7gem
"
I recvd the following reply from Tim at HRD
"Barry,
Unfortunately due to an expired Software Maintenance and Support period, the
Ham Radio Deluxe support team is unable to provide support at this time. According
to your profile information in our license database, your SM&S expired.
Tim
"
I guess you can't report a bug if you don't pay every year.
cheers de Barry


Buz Johnson
 

Berry,

i’ve got an open ticket now for Super Sweeper crashes and Alarms not working.
Hopefully will have it resolved this week.

Buz, WA5AMM 


David Tucker
 

I had the same problem Buz. I gave up on HRD a long time ago.

On 8/2/2021 5:21 AM, Buz Johnson wrote:
Berry,

i’ve got an open ticket now for Super Sweeper crashes and Alarms not working.
Hopefully will have it resolved this week.

Buz, WA5AMM 


Paula K7PAX #1739
 

Well guys - HRD support does not have a fix for the alarms at this time. They entered the problem into their bug tracking system and closed my ticket. It is tracked as bug # 

Buz Johnson wrote:


Berry,

i’ve got an open ticket now for Super Sweeper crashes and Alarms not working.
Hopefully will have it resolved this week.

Buz, WA5AMM 

--
Paula K7PAX #1739


Buz Johnson
 

Paula, 

this is is surly disappointing but if they can fix the crashing in SuperSweeper, it still would be a win.  I’m in the process of having a phone call and maybe a remote secession with a tech.  You, Rich and I have called there attention to the Alert problem in SS so maybe they will address it quickly.  We do know it works in Win 7, so hopefully it’s not something to difficult to overcome.
thanks for your input.

73,

Buz, WA5AMM
PODXS70 #2827 LONP #454 


Barry VA7GEM
 

Paula
Does this bug include the TEST feature not working.
My good friends at HRD have let their true colours
show again when they won't accept a bug report
from me unless I pay their annual fee.
cheers de Barry