Re: (OT) Sharing Com Ports with Virtual Serial Ports Emulator (VPSE) or other application


Rick Harrington
 


Maybe I'm reading it wrong Mike, but when you say you split 4 to 1 then 1 to 2 I think you've thrown in an extra step. 

Using the COM numbers from your message as an example, create your splitter with COM4 as the "Data Source Serial Port" and COM1 as the "Virtual Serial Port".  Then connect ALL your software to COM1.  Make sure the Settings button has the correct info.  That's it!  COM1 will now accept up to four devices and each will think it's connected to COM4.

Now, having said that--I would stay away from "COM1" and "COM2" and give my virtual port a higher number (mine is COM9).  Your PC maybe using those low numbered ports for something else that you don't know about and causing a conflict.  Device Manager is your friend.

Good luck!

73
Rick K0VC


---In 070@..., <mwbesemer@...> wrote :

Hello all… hope those in the path of Irma are safe. 

I've already posted this to the MixW group, but thought it might be worth
posting here.

I’m running the latest version of MixW and would like to continue to use
ACLog for logging. 

I have set up VPSE, but with both applications running, I get an error from
MixW stating ‘The parameter is incorrect’.

I have ACLog running on Com 1 and MixW running on Com 2.  Currently, I am
running VSPE as a splitter, with Com 4 (the radio) split to Com 1 and Com 1
split to Com 2.  Settings are:

Port Speed: 9600
DTR/RTS: No (have also tried Yes)
Parity: No
Bits: 8
Stop Bits: 1
Read Interval Timout: -1

I’ve seen in that others have used VPSE successfully to share the Com Port. 
If anyone would care to share, I’d be very grateful.

73,
Mike
WM4B
PODXS #348

Join main@070Club.groups.io to automatically receive all group messages.